Dune Core Modules (2.4.2)

Classes

struct  Dune::Capabilities::hasSingleGeometryType< YaspGrid< dim, Coordinates > >
 YaspGrid has only one geometry type for codim 0 entities. More...
 
struct  Dune::Capabilities::isCartesian< YaspGrid< dim, Coordinates > >
 YaspGrid is a Cartesian grid. More...
 
struct  Dune::Capabilities::hasEntity< YaspGrid< dim, Coordinates >, codim >
 YaspGrid has entities for all codimensions. More...
 
struct  Dune::Capabilities::canCommunicate< YaspGrid< dim, Coordinates >, codim >
 YaspGrid can communicate on all codimensions. More...
 
struct  Dune::Capabilities::isLevelwiseConforming< YaspGrid< dim, Coordinates > >
 YaspGrid is levelwise conforming. More...
 
struct  Dune::Capabilities::isLeafwiseConforming< YaspGrid< dim, Coordinates > >
 YaspGrid is leafwise conforming. More...
 
struct  Dune::Capabilities::hasEntity< Grid, codim >
 Specialize with 'true' for all codims that a grid implements entities for. (default=false) More...
 
struct  Dune::Capabilities::hasBackupRestoreFacilities< Grid >
 Specialize with 'true' if implementation provides backup and restore facilities. (default=false) More...
 

Functions

template<ALU3dGridElementType elType, class Comm >
struct Dune::Capabilities::DUNE_DEPRECATED_MSG ("Capabilities::isParallel will be removed after dune-grid-2.4.") isParallel< YaspGrid< dim
 YaspGrid is parallel. More...
 

Detailed Description

Function Documentation

◆ DUNE_DEPRECATED_MSG()

template<ALU3dGridElementType elType, class Comm >
struct Dune::Capabilities::DUNE_DEPRECATED_MSG ( "Capabilities::isParallel will be removed after dune-grid-2.4."  )

YaspGrid is parallel.

Deprecated:
This capability will be removed after dune-grid 2.4.
Creative Commons License   |  Legal Statements / Impressum  |  Hosted by TU Dresden  |  generated with Hugo v0.80.0 (Feb 21, 23:30, 2024)